AppleTVを車載してみた

Pocket

IMG_2523

iPhone5ですが、実はまだ入手できていません。初日にSoftbankで予約したものの、プランみてauの方がよくね?と翌日に予約しなおし。そっちが結局まだ入荷連絡なしorz。

まぁ、それはさておきiPhone5にかえて困るのは映像出力。Dockコネクタ変換アダプタ/ケーブルを使用してもダメだし、HDMIやアナログRGBアダプタも現状は発売されておらず、車載仕様ができません。車載に限らず、現状iPhone5で外部に映像を取り出すのはAppleTVにAirPlayするしかない。ならAppleTV積んじゃえばいいじゃない?ってことであんま使ってない720p世代のAppleTVを試験的に搭載していました。車載モニタはアナログRGBなのでATV Proを使用。これは音声が独立でアナログで取り出せるのもポイント。映像は車載モニタ、音声はカーナビに入れたいので、仮にモニタがHDMI入力がついていても使うことができません(カーナビに光入力があればベストなんですが)。てことでATV Proはうてつけ。

■電源の問題

IMG_2521AppleTVはAC100Vが必要ですが、消費電力そのものは数W程度なので安物のインバーターで充分。ただこちらのAV-DA27Kが安い割に薄型で設置しやすく、しかもUSB 5V出力があって、今のUSB 5V専用アダプタがささってるソケットに差し替えるだけで済むのでチョイス。この成りと価格で定格120Wなんだから時代は進歩してますね。写真は前に使っていた80Wのものとの比較。設計意図としてはカップホルダーにおさめるイメージだったんでしょうが、実際にそうしない場合、ゴロゴロ転がってしまって非常に収まりが悪いw。

■AppleTVの画面が映らなくなることがある

これにハマりました。最初はちゃんと映ってたのに、エンジンを切って再度かけ直した時に、AppleTVが起動はする(リモコン触るとカーソル動く音はする)のに、画面が真っ黒、という状態が発生。液晶側は「信号なし」にならないのでなにかしらの信号は来てる。VolceOverをオンにしてフォーカスしたメニューを読み上げる様にしてブラインド操作でいじったところ、この現象が発生している時、画面設定の解像度選択肢に720pと480pしか出なくなる。正常に映ってる時は1024×768や800×600もいる。通常、表示デバイスからはEDIDという信号規格で対応解像度が送られてきて、それをみて選択肢を決める訳ですがなんらかの理由でそれがちゃんと来てないっぽい。ただATV Proに公式サイトのFAQによるとちゃんと対応していることになっている。

あれこれ試行錯誤した結果、どうもAppleTVとモニタを同時にONした場合、EDIDが送られてくるのがAppleTV起動に微妙に間に合わないらしいということ。モニタ点けっぱなしでAppleTVを起動する分にはOKっぽい。自宅に環境移してモニタつけっぱなしで実験すると問題ないのでこれが原因と気付くのに随分時間かかりました。

つまり、モニタの方をちょっとだけ先に電源を入れるようにすればいいわけですが、できれば毎回そんなことはしたくない。手としては、安い順に、

  • AppleTV(のインバーター)側に手動スイッチを入れて、エンジン始動後に自分でONする(あるいはOFF/ONする)
  • AppleTV(のインバーター)側にディレイスイッチを入れて数秒遅れで通電するようにする
  • EDID保持器というEDID疑似信号を常時発生するデバイスをモニタケーブルにはさんで使う

辺りでしょうか。後者が確実そうですが、D-Sub用が数千円、HDMI用が1万円程度します。しかもこの場合、どちらを使うべきかあんまりはっきりしない。安いアナログRGB用でも大丈夫な気もしますが、遅延の理由がATV Proだとすると、それとAppleTVの間、つまりHDMI用でないとダメかも知れない。

ということでEDID保持器を使う手は割だかな上にリスクもあるので、当面は手動スイッチかなぁ。それで問題が起きない様なら追々ディレイスイッチの導入を検討する。そういうしてるウチにRGBケーブル出るかも知れないし。

2012.10.2追記:なぜだかここんところこの問題が起きなくなりました。特に配線とかいじってないんですが。OSを5.1に更新したのも関係してるかな?でもその少し前から症状が治まった気がする。あとiPhone5のテザリングを使ってのAiePlayも快調ですが、たまに2.4GHz電波が多く飛んでいる場所で接続しづらくなることも(主に起動時)。どうもiPhone5のテザリングは5GHzを使ってくれないみたいですね。安い5GHzルーターを車内に設置してもいいんですが、そうするとiPhone5までWANにつながらなくなるので不便かなぁとか思案中。

■AVIC-ZH99HUDのAUX問題

サイバーナビのZH99では音声入力の系統が減って、iPodケーブルとAUXケーブルが排他になっています。ただし、iPodケーブルはDockコネクタからUSBとアナログ4極ピンプラグにわかれています。ナビ本体側には4極ピンジャックがあり、iPodから映像音声を入れる場合はUSBと一緒にこれを接続、AUXで使う時はDVカメラなどでよく使われていた4極ピン->赤白黄のケーブルを挿せ、となっています。しかし幸いなことに、デジタル音声だけならiPodケーブルのUSB端子だけ接続しておけばOKで、空いた本体側のピンジャックに4極->赤白黄ケーブルをつないだところ、iPo
dもAUXもちゃんと使えました。つまりiPod側は音声&充電のみの使用であれば、ピンプラグは不要ってことですね。iPhone5からLightningコネクタで出してDockアダプタ経由でつないだ場合もデジタル伝送は互換性があるので恐らく大丈夫でしょう。というか純正ケーブルは全く不要で、Lightning-USBケーブルを直挿しすればいけるんじゃないかと(黒いケーブルが欲しいなぁ)。

■車内AirPlayの使用感

でまぁ無事に起動するようになったとしてまだ問題はあります。AppleTVとiOSが同じWiFiネットワークにつながる為に、なんらかのWiFiルーターが必要。iPhone5が来たらテザリングする手もあるんですが、毎回車に乗る度にONするとか、常時ONするのは微妙です。解約済みのモバイルルーターもありますが、バッテリーがついてるものは大抵DC入力で自動起動しないので、これまた自分で電源ボタンを操作しなければならない。逆にエンジン切っても電池がある限りは電波出し続けたりするのも微妙。てことでこれまたホーム用のルーターを使うですかねぇ。いまんとこはXperiaSXのテザリングでテストしてます。ちなみにAppleTVは起動時にWANに時計合わせにいくようで、WANにつながってないと毎回エラーになってちょっとウザいです。キャンセルすれば普通に使えますが。

AirPlay自体の使用感は上々。映像RGB+音声Bluetoothの場合よりも明らかに音声遅延が少ない。音質はまぁ音楽じゃなきゃ別に不満はないレベル。ただしAppleTVが起動中の間などに若干アナログ音声にノイズがのるようです。使用中もわずかですが聞こえます。やっぱカーステに光経由で入れたいなぁ…

動画は先読みが効くので、少し時間をおいてからなら「おやゆびでお」でスキップ操作してもサクサク反応します。再生開始直後はさすがにロード時間が発生しますが。

ともあれiOS機になにもつながなくていいのはお手軽です。まぁ長時間使うなら充電は必要でしょうけど。これでiPhone5が来ても問題なく移行できるかなー。

あと、エンジン始動時にモニタにAppleロゴが映るのちょっとカッコいいですよw。Appleカーみたいで。

AppleTVを車載してみた” への1件のフィードバック

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です